Elevated push notification errors

Incident Report for Expo

Resolved

We have confirmed that a fix deployed 24 hours ago has returned APNs notifications availability to normal.
Posted Nov 12, 2025 - 15:40 PST

Monitoring

A fix has been deployed which has greatly reduced the number of failed APNs notifications. Work to improve reliability further is ongoing.
Posted Nov 07, 2025 - 13:44 PST

Update

We've taken action to improve server stability and are investigating the root cause of the "Session closed with error code 11" error to address the increased notification failure rate.
Posted Oct 29, 2025 - 15:20 PDT

Investigating

An increased amount of notifications are failing due to an "apn write timeout".
Posted Oct 29, 2025 - 08:21 PDT
This incident affected: Push Notifications Broker.