Elevated rate of failed iOS submissions

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 13:41 PDT

Monitoring

It looks like the 3rd party API is healthy again. We're going to keep monitoring.
Posted Sep 21, 2026 - 13:31 PDT

Identified

We're seeing an elevated rate of iOS submissions failing. Our logs point to a failing App Store Connect API (502 bad gateway response status code).
Posted Sep 21, 2026 - 13:26 PDT
This incident affected: Expo Application Services (EAS Submit) and Third-Party Services (Apple Developer APIs).