Elevated Workflows and Submit times for free tier users

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 15:24 PST

Monitoring

We're observing unusually high queue times for free tier users on Workflows and EAS Submit. We have taken steps to reduce the queue times. Jobs are being processed and max queue time is steadily decreasing.
Posted Mar 04, 2026 - 13:36 PST
This incident affected: Expo Application Services (EAS Submit, EAS Workflows).