Elevated queue times for high-priority EAS iOS submissions

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 18:04 PDT

Monitoring

EAS iOS submission queue times are returning to normal. We are actively monitoring to confirm full recovery and will provide an update once resolved.
Posted Jun 10, 2026 - 18:02 PDT

Investigating

We are investigating elevated queue times for iOS submissions on EAS Submit.
Posted Jun 10, 2026 - 15:51 PDT
This incident affected: Expo Application Services (EAS Submit).