Some workflow runs are slow to progress

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 08:35 PDT

Investigating

Starting workflow runs from GitHub events and moving workflow runs from one stage to another is currently slower than usual. We're investigating the issue.
Posted Apr 14, 2026 - 06:00 PDT
This incident affected: Expo Application Services (EAS Workflows).