Apple Developer authentication services through EAS CLI may be unavailable for some users
Incident Report for Expo
Resolved
The Apple authentication fix in the latest eas-cli version (12.5.4) has been confirmed by multiple external people. If you are running into this issue, upgrade your eas-cli version - or open a new issue report on https://github.com/expo/eas-cli/issues.

For the latest information see GitHub: https://github.com/expo/eas-cli/issues/2639
Posted Oct 19, 2024 - 11:47 PDT
Monitoring
Upgrade to `eas-cli@12.5.4`, which contains a fix for the Apple authentication issue. We will monitor the rollout until we are confident the issue is resolved.
Posted Oct 19, 2024 - 11:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 19, 2024 - 11:04 PDT
Investigating
Public Apple Developer authentication API has changed, impacting automation tools like EAS CLI. We are currently investigating the issue. You can work around it by running builds with the `--non-interactive` flag, in order to skip authenticating and re-use existing app signing credentials. Follow along with updates on GitHub: https://github.com/expo/eas-cli/issues/2639
Posted Oct 18, 2024 - 18:51 PDT
This incident affected: Expo Application Services (EAS Build) and Third-Party Services (Apple Developer APIs).