Increased iOS submission times

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 06:18 PDT

Update

The issue seems to have been resolved — submission times are back to normal.
Posted Oct 22, 2025 - 06:17 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 22, 2025 - 06:17 PDT

Identified

We're seeing increased iOS submission times. Looks like there's some slowness on Apple's side.
Posted Oct 16, 2025 - 09:18 PDT
This incident affected: Expo Application Services (EAS Submit) and Third-Party Services (Apple Developer APIs).