Higher Android build failure rate

Incident Report for Expo

Resolved

We reenabled the Maven cache to overcome the rate-limiting issue and success/error rates for Android builds are back to normal.
Posted Dec 19, 2024 - 04:52 PST

Update

Some Android builds started to fail with the 429 error code during the "Run Gradle" build phase. We are working towards mitigating this issue.
Posted Dec 19, 2024 - 04:39 PST

Identified

Some libraries, like expo-blur and expo-camera, depend on a library that is hosted on JitPack, which is currently experiencing an outage. If you are using one of these libraries in your project, your build may fail on Android.
Posted Dec 18, 2024 - 15:17 PST
This incident affected: Expo Application Services (EAS Build).