GitHub Builds commit statuses not updating

Incident Report for Expo

Resolved

This incident has been resolved.
Posted May 19, 2025 - 14:40 PDT

Identified

Since 8 PM UTC check run statuses of GitHub Builds are not being updated. We have identified the issue and a fix is being deployed.
Posted May 19, 2025 - 14:19 PDT
This incident affected: Expo Application Services (EAS Build).