Apple Developer authentication services through EAS CLI may be unavailable for some users
Incident Report for Expo
Resolved
Install eas-cli@3.7.2 with `npm i -g eas-cli` and re-run your build/submission if you encountered this issue.
Posted Feb 24, 2023 - 09:25 PST
Monitoring
We have deployed a potential fix in eas-cli@3.7.1. Install this version with `npm i -g eas-cli`, re-run a build and/or submission, and give us feedback on the related issue: https://github.com/expo/eas-cli/issues/1714
Posted Feb 23, 2023 - 13:53 PST
Update
We are continuing to investigate this issue.
Posted Feb 23, 2023 - 11:29 PST
Investigating
Public Apple Developer authentication API has changed, impacting automation tools across the ecosystem, including EAS CLI and Fastlane. We are currently investigating the issue. You can work around it by running builds with the --non-interactive flag, in order to skip authenticating and re-use existing app signing credentials. Follow along with updates on GitHub: https://github.com/expo/eas-cli/issues/1714
Posted Feb 23, 2023 - 11:29 PST
This incident affected: Expo Application Services (EAS Build, EAS Submit) and Third-Party Services (Apple Developer APIs).