Google Play submissions timing out

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Mar 22, 2023 - 13:49 PDT

Monitoring

We are no longer seeing elevated timeout numbers. We will continue to monitor the submissions.
Posted Mar 22, 2023 - 11:42 PDT

Investigating

We are currently investigating an issue where an elevated number of Google Play submissions is timing out.
Posted Mar 22, 2023 - 09:18 PDT
This incident affected: Expo Application Services (EAS Submit).