High queue times and concurrency errors for Android builds

Incident Report for Expo

Resolved

This incident has been resolved.
Posted May 14, 2026 - 14:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2026 - 12:40 PDT

Investigating

Limited availability for Linux workers resulting in higher than expected queue times and invalid concurrency limits
Posted May 14, 2026 - 10:12 PDT
This incident affected: Expo Application Services (EAS Build, EAS Workflows).