We have finished cleanup work for the CI/CD Workflows workers. This was maintenance work and workflow runs were running successfully in the meantime. We are marking this incident as resolved.
Posted Jun 12, 2025 - 14:57 PDT
Update
We have confirmed CI/CD Workflows are running as well. We believe all services are up and see builds, submissions, and workflows running successfully. However, we're continuing to monitor service health for any aftereffects from the large outage.
Posted Jun 12, 2025 - 14:14 PDT
Monitoring
We have verified builds, submissions, updates, and hosting are working as expected. We are testing CI/CD workflows before confirming them as operational. Thank you for your patience.
Posted Jun 12, 2025 - 13:52 PDT
Update
We're monitoring the GCP and Cloudflare outages. Several underlying parts of our services are coming back online and parts of our website are up again. However, loading build pages, viewing hosting metrics and update assets, and delivering push notifications are still offline.
We are continuing to investigate this issue. Still looking like a GCP outage.
Posted Jun 12, 2025 - 11:15 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2025 - 11:11 PDT
Investigating
We are currently investigating. Looks to be a possible GCP outage.
Posted Jun 12, 2025 - 11:09 PDT
This incident affected: Expo Application Services (EAS Build, EAS Submit, EAS Update, EAS Insights, EAS Workflows, EAS Hosting) and Website, Dev Tools API, Classic Update Service (Application Serving API), Push Notifications Broker.