Some EAS Workflows stuck in pending state

Incident Report for Expo

Resolved

The issue has been resolved. A database table lock was preventing workflows from being picked up and progressing. The lock has been cleared and workflow processing has resumed.

Affected workflows that were stuck during this period have been marked as errored with a message pointing to this status page. If your workflow was affected, please re-run it.

We are continuing to investigate the root cause of the lock to prevent this from recurring.
Posted Mar 31, 2026 - 07:30 PDT

Investigating

We're investigating an issue where some EAS Workflows are not progressing past the pending state. Affected workflows show no logs and remain queued. We'll provide updates as we learn more.
Posted Mar 31, 2026 - 06:40 PDT
This incident affected: Expo Application Services (EAS Workflows).