Elevated GitHub errors

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 13:28 PDT

Monitoring

Looks like GitHub API requests are working again!
Posted Jun 17, 2025 - 13:10 PDT

Identified

We're seeing an increased number of "No server is currently available to service your request." errors when calling GitHub API. This influences e.g. processing of webhook events (push, pull request) and setting commit statuses.

See https://www.githubstatus.com/incidents/y7lb2rg4btd7
Posted Jun 17, 2025 - 12:46 PDT
This incident affected: Third-Party Services (GitHub, GitHub API Requests) and Expo Application Services (EAS Build, EAS Workflows).