Increased queue times for EAS Workflows jobs

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 12:37 PDT

Identified

Customers may experience longer wait times for Workflow jobs as we reach worker capacity
Posted Mar 18, 2026 - 10:59 PDT
This incident affected: Expo Application Services (EAS Workflows).