iOS Submission Service Partial Outage
Incident Report for Expo
Resolved
This incident has been resolved. Submissions with updated provisioning profiles succeed normally. Make sure you follow the instructions to delete and create a new provisioning profile if you're still experiencing this error.
Posted Apr 12, 2022 - 18:53 PDT
Monitoring
If your build is affected, you will need to update your app’s provisioning profile and use it to create a new build. You can do this by deleting your app’s existing provisioning profile from the EAS website at https://expo.dev/accounts/[account]/projects/[project]/credentials?platform=ios.
Next, generate a new provisioning profile by running eas build interactively, which will offer to generate a new provisioning profile for you. You can also provide an existing provisioning profile if you already have a valid one.
We are monitoring the submission results for any anomalies.
Posted Apr 12, 2022 - 17:58 PDT
Identified
The Apple iPhone Certification Authority cert and the the Apple iPhone OS Provisioning Profile Signing cert expired at Apr 12 17:43:28 2022 GMT. This is causing provisioning profiles to become invalid. New builds with a new provisioning profile can be submitted successfully.
Posted Apr 12, 2022 - 17:28 PDT
Investigating
iOS App Store submissions can fail with an 'ITMS-90165: Invalid Provisioning Profile Signature' error due to an issue with the certificate chain at Apple. We are investigating the steps needed to resolve this issue.
Posted Apr 12, 2022 - 17:16 PDT
This incident affected: Expo Application Services (EAS Submit) and Third-Party Services (Apple Developer APIs).