App Store rejecting Classic Build iOS submissions with an app thinning error

Incident Report for Expo

Resolved

This incident has been resolved.
Posted Mar 10, 2022 - 19:41 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2022 - 11:13 PST

Update

We have updated the Classic Build service to produce builds without bitcode. Our test builds have been successfully processed by the App Store and we've heard from developers that production builds are being accepted again. We're continuing to monitor this issue in the meantime.
Posted Mar 10, 2022 - 11:12 PST

Investigating

A recent breaking change with the App Store is causing builds created with the Classic Build service (expo build:ios) to be rejected with an error message that says, "While processing your iOS app, errors occurred in the app thinning process."

We are tracking this issue in https://github.com/expo/expo-cli/issues/4253.

We are investigating a potential workaround by disabling bitcode in apps built with "expo build:ios".
Posted Mar 10, 2022 - 10:03 PST
This incident affected: Third-Party Services (Apple Developer APIs).