Elevated pending submissions

Incident Report for Expo

Resolved

A fix was deployed, we've monitored pending submissions, and the incident is now resolved.
Posted Jan 15, 2026 - 11:46 PST

Monitoring

Pending submissions are currently at acceptable levels. We'll continue to monitor the situation throughout Thursday, January 15.
Posted Jan 14, 2026 - 17:41 PST

Identified

We're experiencing an elevated level of pending submissions. We're currently pursuing a fix.
Posted Jan 14, 2026 - 08:00 PST
This incident affected: Expo Application Services (EAS Submit).