Some push notifications are not being delivered

Incident Report for Expo

Postmortem

The Expo push notification service suffered from partial unavailability due to an outage of one of our cache servers. Specifically, we deployed a change that optimized our cache entries to be more compact to improve the performance and efficiency of our caches. However, the cache could not handle the load from evicting the old entries. Clearing the cache solved the problem.

Posted Apr 09, 2026 - 16:46 PDT

Resolved

The root cause has been fixed and our charts confirm availability is back to normal. We apologize for the outage.
Posted Apr 09, 2026 - 16:29 PDT

Investigating

We are investigating a partial outage of the push notification service.
Posted Apr 09, 2026 - 15:25 PDT
This incident affected: Push Notifications Broker.