High submission times for iOS

Incident Report for Expo

Monitoring

iOS submission queue times are recovering to normal rates — we'll keep monitoring until they're fully back to expected levels.
Posted Jul 14, 2026 - 17:12 PDT

Identified

The issue has been identified and we are monitoring queue times.
Posted Jul 14, 2026 - 15:07 PDT

Investigating

We're seeing increased submission times when submitting iOS apps (both queue times and upload times).
Posted Jul 14, 2026 - 14:17 PDT
This incident affects: Expo Application Services (EAS Submit).