Increased EAS jobs wait times for free tier users

Incident Report for Expo

Resolved

This incident has been resolved.
Posted May 05, 2026 - 18:09 PDT

Identified

We're seeing increased wait times for free tier users of EAS. A fix is deploying.
Posted May 05, 2026 - 14:04 PDT
This incident affected: Expo Application Services (EAS Build, EAS Submit, EAS Workflows).